Cannot Preview Metadata in the Subject in Email Templates

Overview

This article explains why it is not possible to see the syntax when testing the addition of Metadata to the subject line of an email template after clicking the Try button in the UI.

Applies To

  • Email Templates
  • Metadata

Cause

If the following syntax is added to the subject line of an email template, clicking on Try will not result in the correct information being sent in the test email:

{{ user.app_metadata.country }} {{ user.email }} {{ user.app_metadata.last_name }}

That is because the UI does not know from which connection the user is coming.

Solution

In order for this type of syntax or any other to be reflected in the email subject, the flow must start from the app itself, not the “Try” button from the UI.