Auth0 Home Blog Docs

Cannot deselect all rules from manual with the VSTS Deploy Extension

bug
vsts
extension

#1

I have 2 rules setup in my account. I’ve added VSTS Extension right now, which works well, but the “rules configuration” tab does not work as expected. I’ve initially set my 2 rules to manual, so to preserve them at my initial project deploy. Then I’ve renamed then and copied the code in files in my project. Tried another deploy and everything went well, from the logs I see the files are picked up but skipped since they are manual.

Now I am trying to set them both as “not manual”, i.e. turn off the “manual rule” flag in the page but it does not work. Opening the developer window in chrome shows nothing is sent on the net when all switches are turned off. If I leave one of the rules on, it works. I suspect there is some problem when the names array of the object sent to the API is empty.


#2

I reproduced the situation and this indeed sounds like a bug related to an update request not being performed to the back-end if there are no manual rules selected. I reported the situation internally to the appropriate team handling these extensions so that they review and address it. As additional information, this may also affect other deploy related extensions so I asked to review the situation in all of them.

For now, the available workaround is to create an empty rule that you can always have set to manual; this way it should be possible to correctly update/switch the manual state of all the remaining rules.

Thanks for bringing this situation to our attention.


#3

Thanks! As an alternative workaround I made the request manually with an empty array using postman.


#4