Cannot delete organization immediately via the Dashboard

I created several organizations by calling Auth0 management API, and I could view them in Dashboard. Then I deleted them via the Dashboard and they have been removed from organization (after several page refreshing).

But when I tried to re-created them via API, I got 400 response which told me that given organization already exists.
I tried this again after about 10 mins, it worked.


Welcome to the Auth0 Community!

I understand you encountered issues with deleting and recreating Organizations.

After my investigation, I did not find the same observations. I tried using the Management API to create the Organizations, delete them in the Auth0 Dashboard, and immediately recreate the same Organization again. During this test, I did not have any issues and had a successful request each time.

In this case, I am unable to reproduce this issue. Since you managed to get it to work after 10 minutes, please let me know if this happens again and provide me with the complete error response.

As an alternative, you could use the Management API Get Organizations endpoint to view your current list of Organizations and then call the Delete an Organization endpoint to remove them.

Hoped this helps!

Please let me know if you have additional questions.

Thank you.

Thanks for your reply, I will keep you updated.