Browser preferred language es-ES does not work with Auth0

Problem statement

In the browser header accept-language, my browser returns es-ES as the preferred language. But when I use this as part of the ui_locales parameter on the /authorize request, it does not work.


We only support the following country codes, most of which are two char in length.

We are supporting the fallback sequence in the browser settings where we will accept es-ES and display the version of Spanish we support es. For ui_locales, we do a more specific match, and the es-ES is an unsupported language for us. As a workaround, you can rely on the browser header language or pass in a valid/supported language value.