Blank Page when Trying to Configure Email Passwordless Connection on Auth0 Dashboard

Overview

This article explains why a blank page will appears on the Email Passwordless Connections settings screen found in the Auth0 Dashboard under Authentication > Passwordless > Email > Configure instead of the email passwordless connection settings.

Applies To

  • Email Passwordless Connections

Cause

This can happen if a PATCH update to the /connections/{id} endpoint of the Auth0 Management API updates the “options” property without specifying the existing sub-properties “email” and “name” in the update. When not specified, the “email” and “name” sub-properties of the “options” property will be deleted from the email passwordless connection JSON file, and the Auth0 Dashboard cannot load the email configuration settings screen to modify the email template, resulting in a blank screen.

Solution

When the “options” property is updated the entire “options” object is overridden. To avoid partial data or other issues like the blank page while viewing the connection on the Auth0 dashboard, ensure all properties are present when updating the “option” object, including all of the previous sub-properties of the options property, as well as the new or updated sub-properties.

Use the Update a connection endpoint to perform the update, using the example below for the typical format:

"options": {
"name": "email",
"email": {
"body": "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transi...",
"from": "{{ application.name }} <noreply@mydomain.com>",
"syntax": "liquid",
"subject": "Welcome to {{ application.name }}"
}
}