Auth0 Home Blog Docs

Authorize button disabled creating new application

Trying to add a new machine-to-machine application in Auth0, gave it a name, selected the API, but the Authorize button stays disabled and I cannot continue? Tried Chrome and Firefox.

I do not see anything special in the documentation either. Did something change, like a new hidden requirement that not even the docs are aware of?

Hey there @constellationdealers!

Nothing I’m aware of. Before I dig in and ask internally can you try getting rid of the cookies and clearing cache and see whether it’s there?

Thank you!

Cleared the cache, closed the browser, back in but still no luck.

Ok! Let me investigate it and get back to you once I have news to share!

So, I figured out it works if I add at least one scope to the API and selecting the scope when creating the application. Are scopes now a prerequisite?

Correct! Yep you need to add scope to the API otherwise it doesn’t make sense as scopes define the specific actions applications can be allowed to do on a user’s behalf. Without it you won’t do much.

That makes no sense. We have never used scopes on this particular API. It is an all on or off.

I have no knowledge of it becoming a prerequisite recently. If it happened so I think the reasoning behind it was that the team wanted to prevent potential developers implementing it having granting-access to users problems in the future.

Let me know your reasoning and discuss it!

There is even an option for “None” in the scopes selection box just above the Authorize button! That makes that option completely useless then.

Anyway, I created a fake scope just so that we can enable the authorize button. Once authorized open the application and deselect the fake scope and save, authorized status remain. Annoying but a work around at least.

ok I’ll reping the team and see what’s the reasoning behind it. Thanks for reporting that!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.