Newly added scopes on machine to machine api calls missing

I have a machine client app calling into an api. This app is authorized for the api and both the api and the app are having the new scopes (as well as some older scopes). On the api side I have some code that looks at the request after running jwtVerify on it and gets the scopes that are on it. The existing older scopes all come through but mysteriously the new ones do not.

What setting am I missing to cause this?

Hi @dchoi,

Thanks for reaching out to the Auth0 Community!

I understand you encountered issues making API calls after adding new scopes to your Machine to Machine application.

First, could you please check if your M2M application has the scopes enabled? To do so, navigate to your Auth0 Dashboard > Applications > APIs > YOUR_API > Machine to Machine Applications and uncollapse your M2M application, select the required scopes (permissions), and press update.

Once that is complete, you can make M2M API calls with your newly added scopes.

Please let me know how this goes for you.

Thank you.

I already did that and was the first thing I checked. Again existing scopes are still working.

Hi @dchoi,

Thank you for your response.

To investigate the issue further, could you please DM me your tenant name and the API name that you have trouble using?

Thank you.