Auth0 Home Blog Docs

Auth0 Machine to Machine permission in JWT

Hi there,

I have a question related to Auth0 Machine to Machine application’s permission setup.

We have a single API, both a SPA and Machine to Machine applications will have access to this API

For authenticating through the SPA, we’ve got the permissions as a permission after decoded the JWT
image

But when authenticating through the Machine to Machine application, it will become a scope property
image

Is it a normal behavior? Is there a way to unify the property name? thanks

Hi @kwintenli,

Welcome to the Auth0 Community Forum!

It looks like this has been addressed here;

Can you take a look and see if adding option described in that response solves the issue?

If not, please let me know and we can evaluate further strategies.

Thanks,
Dan

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.