Auth0LockPasswordless `allowSignUp: false` option does not work

I’m creating a custom login with Lock. ( I’m using Auth0LockPasswordless.
I’m trying to separate login and signup with passwordless, as explained here: Separate Passwordless Login and Signup.

So I’m doing a ternary selection on the option allowSignUp. When I try to signup passwordless with the option allowSignUp:false, a new user can register, when It shouldn’t.

Also on Auth0LockPasswordless the option additionalSignUpFields does not work:
Check the following example:
additionalSignUpFields: [{ type: "checkbox", name: "newsletter", prefill: "true", placeholder: "I hereby agree that I want to receive marketing emails from your company" }, { type: "checkbox", name: "terms", prefill: "true", placeholder: "I agree terms and conditions" }]

Mariano Vicario

Hi @MarianoV,

Welcome to the Auth0 Community!

First, to disable sign-ups, you need to navigate to your Passwordless Type (SMS or Email) and scroll to the bottom of the settings page and enable the Disable Sign Ups toggle.

Once that is complete, your Universal Login page will not allow users to sign up using Passwordless.

If you decide to allow sign-ups, I recommend following this related FAQ Topic to accomplish this behavior.

Lastly, the behavior you observed using Passwordless with additionalSignUpFields is expected. The additionalSignUpFields is not allowed with Passwordless and can only be used with database signups (Auth0Lock). See below.

Please let me know if you have any further questions.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.