Applications with Organizations enabled, not being listed on organization invitations

Hi Guys,

I am having issues inviting users to an organization. If I go to an organization and then go to the invitations tab, and then try to invite new members, when I try to look for my application on the drop-down, I cannot find it.

I checked the application, and in the organizations tab for my application, I selected “Business Users” in the “Types of Users” section. I don’t know what else should I do to be able to see my app listed on the feature to invite new members to an organization.

Thanks in advance for the help!

Hey there @hhurtado ,

Thanks for reaching out!

Could you please try to update the client (your app) to require the organization login context with the Management API call, to see if within the response you’ll get any additional error message that will help us understand wat’s wrong?

PATCH {auth0_domian}/api/v2/clients/{id}

body: { "organization_usage": "require"}

Please let us how are things going!

Thanks for the response @marcelina.barycka

I just tried this, when I make the API call I get a 200 response, but even with that, I cannot see the application listed when I try to invite members to my organization.

Something I just noticed, is that I have a lot of applications on my Auth0 tenant, right now I have 287 applications. Maybe this somehow affects the expected behavior?

HI @hhurtado !

Did you get any alert about reaching limits on your current subscription?

Would you be open to create a new test organization, going to invitations and select the affected app to check where potentially you are approaching limits?

Hi @marcelina.barycka,

I didn’t get any alert about reaching limits on my current subscription.

I just created a new Auth0 organization and didn’t notice any alert or warning message. On the new organization, when I try to invite users, the app is still not listed in the applications dropdown

Hey there @hhurtado , thanks for sharing!

There are global entity limits based on subscription / custom subscription plan. For example with the self service paid subscription you can use up to 100 applications. I noticed there are a lot of tenants associated with your email address and if not mistaken, they are subject to a custom agreement.

If the doc I shared doesn’t give you the exact answer, then it’s best to contact a support team via support ticket - does your subscription allow you do that?
Alternatively I can submit a ticket on your behalf. Here in the Community we do not ask for data like tenant name for security reasons, so support agent contacting you would ask you for details.

Please let me know how you would like to go about that!

Hi @marcelina.barycka

Thanks for the help with this issue. I just created a support ticket as you suggested, let’s see what the support team finds.

Something I noticed yesterday is that if I go over the list of applications on my Auth0 tenant, and enable the organizations for the applications on the first page of that view(Like the first 50), then those applications are listed when I try to invite members to any of my organizations, but when I enable organizations for the first application or any application on the second page of the applications view in the dashboard, then the application is not listed when I try to invite members to any of my orgs.


1 Like

I just got a response from the support team.

It looks like this is a known issue and they have something in the backlog to fix it, but unfortunately, they don’t have an expected date for the resolution.

The suggested workaround is to use the Management API to invite users to your organizations.

I just tested this and it works.

I hope this can help someone else in the future.


1 Like

Thank you for sharing with the rest of Community @hhurtado , this is very much appreciated!
Marking your last reply as a solution.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.