Applications or Client Missing from Selection when Sending Invitation to Organization

Problem statement

When inviting a new member to an organization, the Dashboard UI does not list the desired application or client.

Symptoms

When viewing the ‘Invite Members to Organization’ page (Dashboard > Organizations > [Select Organization] > Invitations [tab] > Invite Members [button]), you’ll find a dropdown menu listing associated applications. The application intended for the invitation is not listed even if it exists on the list of applications in the tenant.

Steps to Reproduce

  1. Add more than a hundred applications to the tenant.
  2. Navigate to the ‘Invite Members to Organization’ page (Dashboard > Organizations > [Select Organization] > Invitations [tab] > Invite Members [button]).
  3. Open the dropdown menu of associated applications.
  4. Any application designated with a number above 100 on the dashboard is not listed.

Troubleshooting

Steps that can be taken to identify and verify the problem, including links to internal resources.

  1. Ensure the Application is configured to support organizations. See Login Flows for Organizations
  2. Check if the index number of the application is above 100 on the list of applications in the dashboard.

Cause

This issue can be caused by having more than 100 applications configured in Auth0. The Dashboard uses the Auth0 Management API to get the first 100 applications.

Solution

Invite members via the Management API.

  • To invite members via the Management API: Make a POST to the Create Organization Invitations endpoint (https://YOUR_AUTH0_DOMAIN/api/v2/organizations/ORG_ID/invitations).