Applications or Client Missing from Selection when Sending Invitation to Organization

Last Updated: Sep 5, 2024

Overview

When viewing the Invite Members to Organization page (Dashboard > Organizations > [Select Organization] > Invitations tab > Invite Members button), there is a dropdown menu that lists associated applications. The application intended for the invitation is not listed even if it exists on the list of applications in the tenant.

Applies To

  • Applications
  • Invite Members

Cause

This issue can be caused by having over 100 applications configured in Auth0. The Dashboard uses the Auth0 Management API to get only the first 100 applications.

Solution

To troubleshoot the issue:

  1. Ensure the Application is configured to support organizations. See this documentation for more information.
  2. Check if the index number of the application is above 100 on the list of applications in the dashboard.

If the application is above 100, invite members via the Management API by making a POST request to the Create Organization Invitations endpoint:

  • https://AUTH0_DOMAIN_NAME/api/v2/organizations/ORG_ID/invitations