Overview
This article explains why the “APIs” menu items are visible for some Single-Page Applications but not for others.
Applies To
- Single-Page Application (SPA)
Cause
The applications without the API menu item were not created as Regular Web Applications.
If the application was originally created as a SPA and the application type was later changed to a Regular Web App, the API menu item will not be present.
Solution
Follow these steps to view the APIs tab on the applications settings
- Change the application type to a Regular Web app or M2M
- Change the authentication method for the token endpoint to something other than ‘none’
- For example: Client Secret (post):
- Enable the “Client credentials” grant under Advanced Settings