Problem Statement
Upon visiting the “API Explorer” tab under Applications > APIs > Auth0 Management API, we saw the following error
"Error! API Error. Please contact support if the problem persists"
Cause
This error was due to a very specific condition when there is an empty or invalid Action trigger for client credentials exchange flow. Here is the setup:
- Create a custom action with whitespace in the code.
- Deploy it as an M2M flow trigger
Solution
In the current design, the empty or invalid action trigger code will prevent the client credentials flow. So we need to remove or fix the action trigger.
We have a backlog item for preventing empty action to be deployed.