Overview
This article will cover a potential reason for the error message “Error validating ID Token”. This error is returned by the Android SDK after a login transaction has completed. The following is the message and code the application will return:
“message”: “Error validating ID Token”,
“code”: “a0.session.invalid_idtoken”
Applies To
- Android SDK
- Mobile Development
- Authentication
Cause
This issue was due to specific device configurations that interfered with the SDK’s functionality. Namely, this occurred when the end user had deactivated the Android device’s automatic date and time synchronization.
Solution
For this specific issue pertaining to the date and time of the device, the end user will need to navigate to the following settings page in their Android device to re-enable auto-syncing of date and time:
Once the sync has been re-enabled, authentications should complete successfully.