An Error Occurred When Fetching Client Data for Lock: https://cdn.[locality].auth0.com/client/CLIENT_ID.js

Problem statement

An error may be seen on the new tenant when exporting tenant settings from an older tenant with an outdated version of Lock.js with a custom Login Page. On the new tenant, Lock won’t load correctly . In the browser console, the following message is generated.

Uncaught Error: Error: An error occurred when fetching client data for Lock: https://cdn.[locality].auth0.com/client/CLIENT_ID.js could not be loaded.

Cause

In Lock v11.30.5 a change was introduced to use the domain value for client assets download instead of `cdn.*.auth0.com. The newer localities (PUS4, EU2) don’t serve this information over the cdn by default and use the domain value for client assets download, so using an outdated version of Lock won’t work.

Once the customization toggle is flipped on for the Universal Login page, that page can no longer be automatically updated by Auth0, so the admin would be responsible for updates and maintenance of the page. This includes updating the version numbers for any included Auth0 SDK or widget.

Solution

Update Lock to the latest version.