Auth0 Home Blog Docs

access_denied error when "trying" Microsoft social connection

scopes
social-connection
access-is-denied
microsoft

#1

I just set up my Microsoft social connection. When I hit the Try button, I get the following error message:

{
  "error": "access_denied",
  "error_description": "The provided value for the input parameter 'scope' is not valid. The scope 'wl.signin wl.emails wl.scope' does not exist."
}

The Microsoft connection is set up is as follows:
![alt text][1]
I also tried with the Client ID and Secret values from my app’s configuration on apps.dev.microsoft.com, but that gives me the same error. What could be the problem? Thanks!


#2

I have found the same issues today when attempting to configure the MS social connector


#3

In case it matters, my Google connection works fine.


#4

I’m also facing the same issue. I tried changing permission scope to simple User profile read permission (not even email), and it still doesn’t work and gives the same error.


#5

We have identified a bug with our Microsoft social connection and the fix should reach production in about 48 hours. In the meantime, you can workaround it by patching the Microsoft connection through the Management API with the following body:

{
    "options": {
      "client_id": "",
      "signin": true,
      "emails": true,
      "postal_addresses": false,
      "birthday": false,
      "work_profile": false,
      "basic": false,
      "offline_access": false,
      "calendars": false,
      "calendars_update": false,
      "contacts_birthday": false,
      "contacts_create": false,
      "contacts_calendar": false,
      "contacts_photos": false,
      "contacts_skydrive": false,
      "events_create": false,
      "messenger": false,
      "phone_numbers": false,
      "photos": false,
      "share": false,
      "skydrive": false,
      "skydrive_update": false,
      "applications": false,
      "applications_create": false
    }
}

It doesn’t have the scope attribute, which is what’s causing this issue. You can obtain the connection id from the get all connections endpoint.


#6

@anny - thanks for the update. I’ll try the Microsoft connection again in a few days.


#7

Hello Anny, did you fix this already?
Best, Vadim


#8