A0deploy --no-env not working

Stack

  • auth0-deploy-cli: 7.3.1
  • Nodejs: 16.13.0 & 14.16.1

Objective

Importing/Exporting different tenants (dev, staging) configuration from same project.

Issue

By default, the tool merges with your current environment variables and overrides the config.json file (which has the same top key). You can use the --no-env option to disable the override via the command line.

cf: tenant configuration

I tried to use --no-env but without success, from your codebase in src/args.js the only options define for yargs are debug and proxy_url.

cf: args.js

Workaround

It’s not ideal but working so far, I had to put a .env in each tenant folder to override the root one.
Those .env have the same keys as in my config.json

1 Like

Hi @r.cauquil,

Thanks for reaching out to the Auth0 Community!

I understand that you have observed an issue where the --no-env option is not working with the Auth0 Deploy CLI Extension.

In this case, could you please raise a Github issue so that they could take a look and provide a fix on the problem?

Thank you.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.