Auth0 Home Blog Docs

404 when trying to run auth0 and vuejs in production


#1

Hello,

I’m currently using vuejs for my frontend application. In dev, the authentication works well but when I run in production, the redirection to the callback URL returns a 404. I’m using an nginx docker image to run my server, and I’m using the history routing.

Auth0 redirects me to domain.com//callback#access_token=… and this doesn’t work. I think that because this route doesn’t exist for nginx, and the vue application is not at this URL but doesn’t know how to fix it.

Thank you in advance for your help ! :smiley:


#2

I’ve also tried on a localhost docker image to reproduce what happening in production and I get a 404 error when auth0 is redirecting me to http://localhost/callback#access_token=


#4

Hey there @Sehsyha!

Can you DM me with your HAR file when you reproduce the error in your workflow so I can investigate it further? Here’s more on what HAR files are:

Thanks for that!


#5

Hey @Sehsyha!

We’re looking into it with our Developer Support team. Will get to you shortly!


#6

When running in production, what is the URL of your application, and what is the URL that Auth0 is redirecting to?


#7

In production, the URL of the application is http://crounch.me and the URL Auth0 is pointing to is http://crounch.me/callback