Auth0 Home Blog Docs

React SPA hosted on Heroku with Auth0 not working

Hello everyone,

First of all, thank you to Auth0 for this wonderful product as well as the community on here.

For the problem I’m facing:

I’m trying to host a React app on Heroku with Auth0 and everything is working OK locally. But when I try to login on Heroku it ends up giving me a 404 on the callback route.

Earlier I hadn’t provisioned an Auth0 addon on Heroku but then I did that and tried with my new clientId and new authdomain which was a new url(Idk if I should use it) but still getting a 404 on the callback.

Has anyone ran into the same problem?

I searched for solutions on the forum but none worked for me.

Thanks

Hey there @yash592 and welcome to the Auth0 Community! When you get a chance can you please capture the login workflow that is producing the error within a HAR file. Please keep in mind to select “Preserve log” to catch redirects and scrub the file of user passwords before passing it over in a direct message. I also have included a extensive bog article we did that talks about deploying JS apps which on particular part relates to Heroku for reference. Thanks in advance!


I wanted to follow up @yash592 and see how things are coming on obtaining that HAR file. Please let me know if you have any questions. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.