Auth0 Home Blog Docs

Why can I call my WebAPI successfully with localhost but not my live https site?



I have been using Auth0 for a long time to login and make calls to my API. On January 19, 2018, when I logged into my Production server, the password would not work. It did work when I ran on localhost I changed my login for in the Auth0 panel. Then, I could login both locally and my live site. But, my calls to my WebAPI worked locally but not on Production. I keep getting a 401 error.

In the meantime, I moved to the hosted page for the login since that is recommended. I’m still having the same problem, where I can log in locally and production but I calls to my WebAPI work locally but not on my Production server. I have walked through the code and the token is there and I have checked the token on and the signature is validated. It appears that the Authorization header is not being added on the call to the Production Server. Any suggestions?


@beverly.fay it would be helpful to know the debugging steps you have taken so far


Good news!! I did some debugging of the angular-jwt.js file and I figured out that I had to have both “” and “” in my whiteListedDomains.


Awesome - great to know!