When I use Universal Login Page Templates API, I can't customized Universal Login Page

Hi there.

I would like to customize the Universal Login screen using the Universal Login Page Templates API.
I have set up a Custom Domain for this and sent an update request to the API as described on this page.


But the Universal Login screen is not customized and shows the Default Lock screen.
Please let me know if there is something I haven’t set up.

The customization values are as shown in this page.


When the template is retrieved, the following response is returned
{
    "body": "<!DOCTYPE html><html>  <head>    {%- auth0:head -%}    <style>      body {        background-image: radial-gradient(white, rgb(200, 200, 200));      }      .footer {        background-color: rgb(120, 120, 120);        position: absolute;        bottom: 0;        left: 0;        padding: 16px 0;         width: 100%;        color: white;        /* Use a high z-index for future-proofing */        z-index: 10;      }      .footer ul {        text-align: center;      }      .footer ul li {        display: inline-block;        margin: 0 4px;      }      .footer ul li:not(:first-of-type) {        margin-left: 0;      }      .footer ul li:not(:first-of-type)::before {        content: '';        display: inline-block;        vertical-align: middle;        width: 4px;        height: 4px;        margin-right: 4px;        background-color: white;        border-radius: 50%;      }      .footer a {        color: white;      }    </style>     <title>{{ prompt.screen.texts.pageTitle }}</title>  </head>  <body class=\"_widget-auto-layout\">    {%- auth0:widget -%}    <footer class=\"footer\">      <ul>        <li><a href=\"https://company.com/privacy\">Privacy Policy</a></li>        <li><a href=\"https://company.com/terms\">Terms of Service</a></li>      </ul>    </footer>  </body></html>"
}

Have you already checked that you do NOT have the classic experience selected (https://auth0.com/docs/universal-login#choosing-an-experience)? In addition, have in mind that even if the new experience is selected in that selection screen, **you will also need to ensure that in the Login page tab you do not have customization toggle enabled.

When the Customize Login Page is enabled this will override the experience selection and force classic experience.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.