WebAuthProvider.login(account) throws "Not Found." only on Samsung S20 (Android 12)

Please include the following information in your post:

  • Which SDK this is regarding: Android auth0 SDK
  • SDK Version: 2.7.0
  • Platform Version: Android 12 (API levels 31, 32)
  • Code Snippets/Error Messages/Supporting Details/Screenshots:

When calling WebAuthProvider.login(account) the login form appears correctly and after enterring my login information and proceeding, the page shows “Not found.” at the top left corner and it does not return to the app. This scenario happens only on my Samsung S20 (running Android 12, kernel 4.19.87-24107789, build SP1A.210812.016.G980FXXUEFVDB).

I’ve tried multiple Android simulators running Android 12, 11 and 10 – and all login correctly and return to the app as expected. The same code also works on an older Android device running Android 7.

I was able to reproduce the issue only on the S20.

I’ve tried reinstalling the app, rebooting the device and clearing Chrome’s cookies but nothing helped, unfortunately.

Any tips to solve this are greatly appreciated!

Hi there @justinas.vilimas welcome to the community!

Super peculiar it’s only reproducible on the 1 device :thinking: The only other time I can recall seeing something similar the issues was related to auth0Scheme:

Just throwing out ideas here, but is there another app with a similar configuration installed on the device? Do you run into the same issue using one of our sample apps?

Let us know!

Hi tyf,

Thanks for the tips. I’ve tried the Android sample app and getting the same “Not Found.” message after authorizing on the S20. Could it be related to wrong configuration on our Auth0 account?

Would be strange since authentication works on iOS and non-S20 Android devices.

You mentioned auth0Scheme. We’re using “https” as our auth0Scheme – could this be the cause?

Thanks again.

No problem, happy to help! Thanks for following up here :smile:

I agree with you on this in that it would be surprising to me if this was related to your Auth0 configuration given it works everywhere else.

Out of curiosity, did you change this in the sample app? It’s set to use auth0Scheme: "demo" by default. In testing on my personal device (Pixel 5a Android 12) I run into the not found issue when I set the scheme to https, but it works fine if I set it to a custom scheme like “demo” which the sample apps use by default. This is helpful:

Thanks tyf,

Changing the auth0Scheme solved my problem! :partying_face: Looks like the newer Android versions do not like auth0Scheme to be set to “https”.

A suggestion: updating your official documentation might help for future developers, right now it explicitly states to use “https” for auth0Scheme (which I was following initially when integrating Auth0 into our app). Here specifically: Auth0.Android

Anyway, huge thanks!

Happy to help!

That’s good to know! Thanks for confirming here :smile: I also agree that the documentation around the auth0Scheme could be improved - Appreciate the feedback!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.