Using Auth0.OidcClient in Xamarin gives namespace not found

I’m encountering a tedious problem when I use the Auth0 in Xamarin (Android side).

I followed the official QuickStart guide but when I write “using Auth0.OidcClient”, it looks red underlined and it says that a namespace doesn’t exist.

I tried to install it from console and Nuget manager. Nothing
I tried to install it in the shared solution (neither Android or iOS). Nothing

Hey there @luca.panariello, welcome to the Auth0 Community!

Are you able to confirm the package is installed on the project? Can you share the quickstart guide you are leveraging currently?

Thanks!

  1. yes, it is installed using nuget package and console.
  2. https://auth0.com/docs/quickstart/native/xamarin but I’m using it on Heroku, so the quistart guide is the same but fields are filled of course
    Anyway the issue is in C#

Can you share a bit more details on the Heroku implementation and the goal there? Thank you.

First of all the problem is on C# (Visual Studio Community 2019), not on Heroku.

Anyway, I’ve followed this guide:

  1. Install the package throught this instruction: Install-Package Auth0.OidcClient.Android
  2. I paste this code in my login page (.cs file):

using Auth0.OidcClient;

var client = new Auth0Client(new Auth0ClientOptions
{
    Domain = "<provided by heroku>",
    ClientId = "<provided by heroku>"
});

The error turns out when I wrtite the code using Auth0.OidcClient;
It looks like the package is not installed, but It is. I even checked the installed packages list.

I am facing exactly the same issue, did you find a solution?