Users Import / Export extension not working

Hi, I’m testing out the users import/export extension (User Import / Export Extension), and it’s failing even when I upload using the json content presented in this example. Bulk User Import Database Schema and Examples

I don’t understand why that’s a bad request. What might be going on?

1 Like

I’m having this same issue. I’m trying to use the Auth0 User Import/Export Extension to experiment with importing users from our database. I keep getting back “Oh snap! You got an error! An error occured while uploading the file: Bad Request”.

The problem I’m having is that there is no additional information I can use to debug the issue. Was my input file malformed? Is the service misconfigured? etc. I am able to successfully export users using the extension, so it doesn’t seem to be a problem with the extension’s connection to my tenant.

I tried formats like this:

    "email": "...",
    "email_verified": true,
    "username": "<same as email>",
    "user_id": "...",
    "family_name": "Joe",
    "given_name": "User",
    "name": "Joe User",
    "password_hash": "$2b$10$<bcryptdata>"

and also tried the sample from this page:

    "email": "",
    "email_verified": false,
    "app_metadata": {
        "roles": ["admin"],
        "plan": "premium"
    "user_metadata": {
        "theme": "light"

Where can I see more detailed logs so I understand what’s going wrong?

I managed to use the Management API explorer to test the import via the API, and it returned a better error “Connection is not enabled”.
I did not have any applications enabled for my username & password database connection, because we are using Organizations. After I enabled at least one application for the username & password database connection, I was able to complete the import.