Updating Entity ID and Callback Endpoint (ACS URL) Values for an Okta SAML Integration

Overview

This article provides troubleshooting steps for an infinite loop that can occur when configuring SAML-based Single Sign-On (SSO) integration between Okta and Auth0 for the dashboard members.

Applies To

  • Dashboard Single Sign-On (SSO)
  • Okta (SAML)

Cause

The infinite loop is caused by incorrect values entered for the Entity ID and the Callback endpoint (ACS URL) within the Okta SAML application settings.

Solution

To correctly configure the integration, update the SAML settings within the Okta application.

  1. Create a SAML application in Okta. NOTE: Placeholder values may be necessary until Auth0 Support provides the SSO connection’s name.
Property Value
Entity ID urn:auth0:auth0:{assignedConnectionName}
Callback endpoint (ACS URL) https://auth0.auth0.com/login/callback
  1. Update the configuration in the Okta SAML application with the exact values below. [image placeholder]

    • Single sign-on URL - https://auth0.auth0.com/login/callback
    • Recipient URL - https://auth0.auth0.com/login/callback
    • Destination URL - https://auth0.auth0.com/login/callback
    • Audience URI (Entity ID) - urn:auth0:auth0:<assignedConnectionName>
  2. Ensure there are no other URLs in these fields unless required by a specific advanced configuration. The values must be an exact match, with no extra characters or trailing slashes. For further details, refer to the Auth0 documentation on configuring single sign-on.