Getting error while integrating SAML (Okta)

I am trying to integrate OKTA as iDp with auth0. what’ll be the SSO URL for Okta in case auth0 is SP.
I tried https://YOUR_DOMAIN/login/callback?connection=YOUR_CONNECTION_NAME. But in my case it’s a react bundle running on localhost and Okta does a HTTP POST on https://YOUR_DOMAIN/login/callback?connection=YOUR_CONNECTION_NAME which can’t be processed, what’s the right way to add SSO URL.

Hi @raja , welcome to the community!

If Auth0 is the Service provider, the SSO URL should be the login endpoint for the IdP (Okta in your case), and the Assertion Consumer Service URL on the Okta side would be pointed at your Auth0 tenant’s domain - not localhost. E.g. https://<yourTenantName>.<region><YOUR_CONNECTION_NAME>

You can check the value for YOUR_DOMAIN in any of your Auth0 app’s settings page.

Once that is configured, Auth0 would then be able to send the request to Okta via the SSO URL, which in turn could send the SAML response to the ACS URL which should be your Auth0 tenant, for processing after successful authentication. Auth0 would then finally redirect to your app using the allowed callback URLs configured for your app. Please see the guide here for setting Auth0 up as an SP:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.