Update "Types of Users" Setting Under Organization Tab

Overview

This article explains why the Organization tab disappears from a Machine-to-Machine application after switching to Business Users on that tab and then clicking away from the tab.

The tab is available before selecting Business Users:


But after selecting another tab, the Organization tab disappears:

Applies To

  • Machine-to-Machine (M2M) applications
  • Organizations

Cause

This happens because the Authorization Code from Grant Types was not selected.

Solution

  1. Go to the Auth0 Dashboard and select Applications.
  2. Select the application and then select Settings > Advanced Settings > Grant Types
  3. Check Authorization Code. After doing this the Types of Users setting will be available again.

    After making the change, disable the Authorization Code grant type for the M2M app.