Unable to delete tenant

I have tried to remove the tenant but cannot.

Tenant Settings > Danger Zone > Delete

The following error is displayed in red.

“All” options must be accepted

Can anyone give me some advice?

Hi @cpvytn :wave:

Welcome to the community :sunglasses:

:thinking: I would perhaps suggest double-checking that you don’t have any leading or trailing spaces in the dialog box where you enter the Tenant Name. And then perhaps un-check and re-select all the options before you try the delete operation again :man_shrugging:

Hope this helps :slightly_smiling_face:

1 Like


Have you actually succeeded in removing the tenant?

If there is a space before or after, the error you will see is as follows

“Entry” does not match Tenant Name

Please stop misleading us with false information.

:wave: @cpvtyn

Thank you for the feedback :slight_smile:

I have indeed deleted an Auth0 tenant on more than one occasion and haven’t experienced the problem(s) you encountering. :thinking: perhaps it is a regional issue, as most of the tenants I have ever deleted were using the North America/EMEA regions for Public Cloud. Anyway, I was simply suggesting some possible options to try; sorry to hear you are still having issues and I wish you all the best in trying to resolve your problem.

Kind regards :sunglasses:


It is not a regional issue. Your information is again incorrect.

Because I created a new tenant in a different region to try to delete the tenant, and just to be sure, I deleted all applications, all deletable APIs, all actions and flows, etc., and then tried the deletion.

Additionally, I created a new Auth0 account and confirmed that the issue reproduced as well.

The problem still reproduces itself, which is why I asked this community.

When was the last time you attempted to delete a tenant?
Please answer exactly.
Changes made to the system between the date and time you last deleted a tenant and the present are causing the problem.

Thanks for the update @cpvtyn :sunglasses:

When was the last time you attempted to delete a tenant?
Please answer exactly.

:thinking: Well, I literally just deleted a public cloud Auth0 Tenant - at 15:28 BST - that was previously provisioned in the EU region. It worked perfectly…as in my tenant was successfully deleted. The deletion was performed via the Auth0 Tenant Dashboard (Settings->Advanced) and using Google Chrome browser Version 114.0.5735.90 (Official Build) (arm64).

It is not a regional issue. Your information is again incorrect.

In the main, Community is a collaborative best-effort discussion forum, and where a solution to an issue is not clear-cut folks try to help each other out as best as possible. If you have a specific issue with the Auth0 platform that requires more in-dept investigation then often Auth0 Support can be a more effective route for problem resolution.

Again, I am sorry my suggestion(s) were not able to provide you with the answer(s) you need.

1 Like


Google Chrome browser Version 113.0.5672.126(Official Build) (arm64)

The problem is reproduced in the EU region.

Hey there!

We’re looking into that. Trying to confirm with engineering if indeed there is some issue with specific browsers and versions. Sorry for the inconvenience and thank you for your patience!

Thank you @peter.fernandez for helping on this one!

1 Like

Just confirmed with the engineering team that there is no issue on our end and I have another user struggling with this who followed @peter.fernandez advice and it worked for them. Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.