Auth0 Home Blog Docs

Unable to connect OKTA as an Social connection

Hi All,
We are trying to connect OKTA as a social provider for Auth0. After following instructions ( https://auth0.com/docs/protocols/oidc/identity-providers/okta ) , we are facing the following error
{
“statusCode”: 403,
“data”: “{“error”:“invalid_grant”,“error_description”:“Invalid authorization code”}”
}

The OKTA logs suggest a successful login but the Auth0 logs show a failure in exchanging tokens.
{
“date”: “2020-01-15T06:52:56.760Z”,
“type”: “feacft”,
“description”: “Invalid authorization code”,
“connection_id”: “”,
“client_id”: “AgDbMtaVg0QkFBloR3nJt_XxswdbWjdD”,
“client_name”: “All Applications”,
“ip”: “35.160.3.103”,
“user_agent”: “Other 0.0.0 / Other 0.0.0”,
“details”: {
“code”: “*************huf”,
“device_id”: “v0:a9286bf0-3763-11ea-a1a2-d1215260b6cd”
},
“hostname”: “ayatana.auth0.com”,
“user_id”: “”,
“user_name”: “”,
“log_id”: “90020200115065259624000556831240605771216821007396372578”,
“_id”: “90020200115065259624000556831240605771216821007396372578”,
“isMobile”: false
}

Please can you help. It will be ideal if we can get on to a call and discuss.

Hi @amlan.chowdhury,

Welcome to the Auth0 Community Forum!

I noticed this issue got picked up by our support team. I am going to repeat their recommendations here for posterity.

Social connections are extensions so can be a bit tricky to debug. We recommend you try implementing Okta through the Open ID Connect (OIDC) Enterprise flow - https://auth0.com/docs/connections/enterprise/oidc.

Thanks,
Dan

Thank you Dan. Setting it up as an enterprise OIDC connection worked. I will recommend the incorrect documentation :).

1 Like

Glad it worked for you! I’ll try and pass this info along. Thanks for being responsive.

1 Like

I submitted a doc change request about the issue. Thanks again!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.