Trying to validate Access token with Auth0 PHP, but I get The JWT string must contain two dots

I’m trying to validate the access token I receive from my react native app in the backend using the Auth0 PHP package. But I keep getting the following error

Auth0\SDK\Exception\InvalidTokenException: The JWT string must contain two dots in Auth0\SDK\Exception\InvalidTokenException::badSeparators() (line 42 of /Users/USER/Sites/APPNAME/vendor/auth0/auth0-php/src/Exception/InvalidTokenException.php).

But checking the token I’m sending, it does contain 2 dots, here is what I’ve done in the backend:

Is there anything I’m doing wrong?


Hi @mmmaxxx,

Welcome to the Auth0 Community!

Could you provide an example token you are seeing? Have you tried decoding it with

Hi Dan
Here is an access token:


I’ve tried decoding it with but without success


That appears to be an opaque token. You will need to request a JWT. Here’s an FAQ about it:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.