Trouble setting up react native sample app


I am new to using Auth0 and am trying to integrate Auth0 authentication into a react Native application that I have been building. In order to see how the auth0 authentication flow should work, I decided to downloaded the react-native Auth0 sample app. After following the instructions to set it up I was able to launch the sample app, but when I clicked on the login link in the ios simulator, I got an error in the chrome debugger that said, ‘Error: Missing NativeModule. Please make sure you run `react-native link react-native-auth0’. I tried linking the react-native-auth0, but then got a message saying, “react-native-auth0” is already linked. If anyone can give me some advice on how to solve this problem, I would be grateful.

Hey there @silversteinmahogany!

I reached out to the sample repo maintainers and opened an issue on your behalf as they will probably provide you with the solutions in the quickest way. You can find it here:

If you can share the outcome of your discussion with the rest of community so that other can benefit it will be perfect!

Thanks, I appreciate your help.

1 Like

No worries, we’re here for you! It will be great if you can share the solution with the rest of community once you have it worked out in the GitHub issue. Thank you!