Auth0 Home Blog Docs

Timeout error with checkSession in V9 angular app

angular4
checksession
v9
501

#1

I am using the sample app provided here. It is an angular application. Login is working fine but when I click on renew token button. it makes a request to http:///authorize? client_id=& response_type=token%20id_token& redirect_uri=http%3A%2F%2Flocalhost%3A4200%2Fcallback& scope=openid%20profile& state=Eolu~Gbpbsuh3nReCez4PuzY9_na54RD& nonce=V5hdPBRZUe0Y0oL0NgLJVx090AEtpUcP& response_mode=web_message& prompt=none& auth0Client=

This returns an error 501 Not Implemented. Then it comes to checkSession method with error

Could not get a new token (timeout: Timeout during executing web_message communication).

I have added http://localhost:4200 in Allowed Origins (CORS) list of my client setting.


#2

Any answers to the above question?
I’m seeing the same thing. Using Auth0js v9. Login proceeds normally.
Invoking checkSession() results in a Timeout plus a 501 Not Implemented for the corresponding /authorize API call


#3

anyone? I am also having the same problem. renewAuth works, checkSession does not


#4

This was happening because web_message communication was not enabled in Auth0 client settings. To enable this you have to go yo clients-> settings-> Allowed Web Origins and add all the URLs from wherever you want to perform silent re-authentication.

Earlier this field was not visible in my auth0 version. If you are also not seeing this option in your client settings than contact auth0 help and get your auth0 appliance updated to latest version.

NOTE: Allowed Web Origins and Allowed Origins (CORS) are two different fields inside client settings and you have to set urls in Allowed Web Origins