The application throws an error about no browser compatible or installed

Problem statement

The application throws an error about no browser compatible or installed.

Symptoms

Main error:
a0.browser_not_available: No compatible Browser application is installed… Error thrown null.

Depending on the SDK, there could be another symptom.

Flutter complete error log:
Non-fatal Exception: io.flutter.plugins.firebase.crashlytics.FlutterError
a0.browser_not_available: No compatible Browser application is installed… Error thrown null.
MethodChannelAuth0FlutterWebAuth.invokeRequest (method_channel_auth0_flutter_web_auth.dart:45)
MethodChannelAuth0FlutterWebAuth.login (method_channel_auth0_flutter_web_auth.dart:21)
WebAuthentication.login (web_authentication.dart:61)
Auth0ServiceNew.performSignIn (auth0_service_new.dart:50)

Steps to reproduce

Log in or log out with an Android SDK-installed application.

Troubleshooting

  • Search the error in our internal DB for updates or KCS articles
  • Search for the error in external resources
  • Reproduce and test with an Android app that uses our SDK if it’s possible

Cause

When the user tries to log in or out, the SDK opens a browser tab to call the Auth0 login/logout API endpoint (an URL). If the SDK can’t find a browser to open the URL, the “a0.browser_not_available” error is thrown.

We don’t have visibility to this information because the error occurs on the user’s device, and the SDK doesn’t report errors to Auth0. We can only investigate the errors on the Auth0 server side (for example, an API call to Auth0 that fails).

Solution

These errors are far from our reach because it requires some action taken by end-users, as to fix this, the user must ensure they have a browser installed on their Android device and that the app has access to it.

We suggest the following troubleshooting steps:

  1. Check that you have a compatible browser application installed on the device. If not, install a compatible browser application like Google Chrome, Mozilla Firefox, or Microsoft Edge.
  2. If you already have a compatible browser installed, try clearing the cache and data of the browser application.
  3. Try restarting the device to clear any temporary system files that could be causing the issue.
  4. If the issue persists, try uninstalling and reinstalling the application, making sure to grant any necessary permissions during the installation process.
  5. If none of the above steps work, contact us for further assistance.