The 10 DLC Registration through AWS Keeps Getting Rejected

Overview

When trying to register a 10DLC phone number through AWS, the 10 DLC registration keeps getting denied due to not satisfying the Opt-In requirements. The requirements for the Opt-In workflow can be found here: 10DLC campaign registration form

Applies To

  • Multifactor Authentication (MFA)
  • Phone Message MFA

Cause

All of the requirements from the AWS 10 DLC campaign registration form need to be met, or the registration will be rejected.

Solution

Using page templates, the requirements for how the MFA page should appear can be customized. See Customize Universal Login Page Templates for detailed instructions.

  • For example, the Terms & Conditions can be added to the footer of the page.

The description of the flow is:

  1. Users navigate to the website.
  2. They click on login.
  3. The login form asks the user to enroll in MFA using SMS.
  4. The users provide their phone number when they log in for the first time, and that is considered consent.
  5. The MFA enrollment is the opt-in f