(still issues with) 401/Unauthorized when obtaining token in Authorization Code grant

From 401/Unauthorized when obtaining token in Authorization Code grant

This bug should be resolved now. Please open a new thread if you have issues.

Still an issue (got stuck on this just following the tutorial).

This recipe makes it work:

  1. Create a new tenant
  2. Set it up (e.g. callback URL’s)
  3. Confirm 401’s when sending in a valid code to /oauth/token
  4. Change “Application Type” to “Regular Web Application”
  5. (not needed - couldn’t find a place to do it either…) Change “Token Endpoint Authentication Method” from “POST” to “None”. (Seems to be important part
  6. Confirm modal “… will disable the Client Credentials grant for…”
  7. Confirm happy path (receive 200/OK when sending in that code to /oauth/token)

Not the best first impression…

yep I just ran into this issue as well - not a great start for Auth0 as I’m evaluating auth providers to use with my app.