Auth0 Home Blog Docs

SAML response via default login URL


Is there anyway to get a SAML response via https://{auth0.domain}/login?client={client ID} as opposed to via https://{auth0.domain}/samlp/{client ID}

I have noticed that you can specify a protocol parameter like so: https://{auth0.domain}/login?client={client ID}&parameter=samlp but I do not get a SAML response when I do that. Is this even possible?


If you want a SAML response, the authentication should be initiated with a /samlp/CLIENT_ID call. If the user already has a session (SSO), Auth0 will directly return back to your app with a SAML response. If not, it will display the login page which has a /login?... URL.

The /login?... URL should never be called directly.


I see, thank you very kindly!

1 Like