Auth0 Home Blog Docs

SAML metadata entityID issue - Auth0 as IDP

saml
#1

I am using Auth0 as IDP using SAML (as addon for application) and have many application on one account.
but i have encountered with the issue:
I have same entityID in Identity Provider metadata for each applications.

<EntityDescriptor entityID="urn:flextest.auth0.com" xmlns="urn:oasis:names:tc:SAML:2.0:metadata">

Every application has same entityID. I should be able to change that parameter or it should be unique.
How i can resolve it?

Thank you for fast answer.

1 Like
#3

Hi there @ibaievskyi!

Happy to help! A few words on this one:

Common settings here are that the Entity ID of the Service Provider is: urn:auth0:YOUR_TENANT:YOUR_CONNECTION_NAME and it’s a default value.

Looking at the doc, it seems that if you’re using same connection for all those apps under this tenant the entityID will indeed be the same for every app.

Let me know if that helps, otherwise I’ll dig further!

#4

Thank you Konrad,
But in our case we don’t use the connections, because we are using the addons for SAML, and connections is used for Auth0 when it is SP. We are using Auth0 as IDP.

#5

The issue is still unresolved. If someone can help me, I will be grateful.