Overview
When a user attempts to authenticate on the Salesforce login screen, it initially appears that authentication is successful. Auth0 receives the code and state in the callback, but the flow immediately fails. In the Datadog logs, the following error is generated.
UNABLE_TO_VERIFY_LEAF_SIGNATURE
On the client side, the following error is generated.
{
“error”: “invalid_request”,
“error_description”: “failed to obtain access token”
}
Applies To
- Auth0 Salesforce Social Connection
Cause
This issue occurs because the certificate chain presented by the remote IdP server (Salesforce) is either incomplete, self-signed, or not issued by a Certificate Authority (CA) that the Anypoint Platform trusts.
This is a Salesforce-side issue and must be addressed by the Salesforce team.
Solution
To resolve this issue, contact Salesforce Support to correct the certificate related problem.