Auth0 Home Blog Docs

Rules not applied for new users, after disabling/enabling signup

Hello, I’m running into an issue and can’t figure out where the problem is.

I had setup an app with the database connection, and created an account with my personal email, and everything worked just fine.

I was happy, and I disabled the signup from the database settings.

A few days later, I am now ready to take in new users, so I re-enabled the signup.

Now I run into an issue with new users/logins because it seems that the rules are never executed.
I have 2 rules, one to sync the users on my database, the other to customize the JWT, neither the rules work :frowning:

Login/logout with my first user still works fine, that’s why I guess is something related to the new users, possibly some trigger deleted after I disabled the signup?

Update: I deleted/recreate the rules and not it seems it works.

I believe is some kind of internal trigger that get disabled with the signup but not re-enabled when the signup is re-activated.