Problems building the react-native sample

Trying to get the react-native quickstart app running. It builds cleanly, but when it starts up it seems there is some problem with metro/bundle/babel - I am not sure: but the console and UI both show an error like this below which suggests some bad JS build configuration or the like. StackOverflow had a few suggestions that didn’t work for me. Any help here would be great as I can’t get very far if this sample doesn’t work :frowning:

error: index.js: /Users/XXX/repos/auth0-react-native-sample/00-Login-Hooks/index.js: Cannot read properties of undefined (reading 'addHelper')


Hey @eric.bloch welcome to the community!

I’ll need to pull down the sample and test myself, but is this specific to Android, iOS or both?

It was iOS specific. (Android build fails for other reasons :slight_smile: ) Fwiw, when i tried running with some versbose/debug flags from the command line via npx or npm (not sure now sorry!), somehow, magically things worked and now they work even without the debug/verbose flags. I lost my command line history sadly, so can’t share wha’happen.

1 Like

Hey @eric.bloch thanks for confirming! I’m glad to hear things are working as expected now :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.