PingFederate "Invalid Thumbprint"

I’m working on integrating a Laravel application with Auth0 SSO. When we attempt to log in, we are getting the following error description:

“Invalid thumbprint (configured: CBD3C6F2C1779C314430AF8CAB1436E61C01AF57. calculated: D318AFCF48BC5BC02B51C759C3D27F316B66B8EA)”

I have been looking around and can’t find any documentation surrounding these errors, can anyone help point me in the right direction?

Hi @stanley,

Welcome to the Auth0 Community Forum!

Have you tried this:

Hi @dan.woda,

The X509 Signing Certificate was provided a couple of days ago and has not changed since we configured it.

Do we need to provide them with a new metadata file if any changes are made to the connection within Auth0? I have changed some settings while troubleshooting but did not provide them with a new metadata file, not sure if that’s required or not.


Bumping this on Monday for visibility, thanks!

We have confirmed that the x509 signing certificate has not changed but are still experiencing this issue.


Looking at some previous support cases, it appears that this can be a result of pingfederate not having the correct certificate.

Have you tried downloading the cert and uploading it to pingfederate as shown here?

Yes we have confirmed we are using the correct certificate.

A few more questions:

  • Do you have multiple certs?
  • When was the last time you changed it?
  • Can you DM me your tenant name please?

This is the only cert. I am not the IdP so I’m not sure the last time they changed it, but it’s certainly live and working. I will DM you Tenant.

1 Like