Payload validation error on application crea

As part of a Pluralsight course I entered callback URL and logout URL but when I submit I get an error
‘Object did not pass validation for format absolute-https-uri-or-empty: https://localhost:7039/authenticaltion/login-callback’ on property initiate_login_uri (Initiate login uri, must be https).

Hi @rkevinburton,

Thanks for reaching out to the Auth0 Community!

Firstly, the callback URL and logout URL values should be assigned to the callbacks and allowed_logout_urls parameters when creating an application.

Therefore, in this situation, I recommend that you set your callback URL(https://localhost:7039/authenticaltion/login-callback) to the callbacks parameter in your create an application request.

Secondly, the initiate_login_uri should be a URL that points to your application’s /authorize endpoint and cannot point to localhost. Given that, I recommend that you set your application’s login URI something like the following:

Check out our Configure Default Login Routes documentation for more information

I hope this helps!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.