Auth0 Home Blog Docs

Passwordless SMS: trying to log back in with an active session, "no phone_number or verification code"

Hi everyone. The engineering team has found the issue that is causing this behavior, and they are currently working on a fix. Thanks to everyone who took the time to report this and provide all this valuable information.

1 Like

Thank you very much @nicolas_sabena ! Have just tested & confirmed behaviour is back to normal: hosted login page respects the prompt: login parameter again :slight_smile:

1 Like

Hi @nicolas_sabena,

Thanks for the update - Unfortunately the prompt=login parameter issue with the hosted page is still not working for us. Please confirm once the fix has been rolled out to all.

Many Thanks

1 Like

The fix was deployed for free tenants yesterday, and should arrive to production tenants today after 1PM UTC.

This incident if being tracked at http://status.auth0.com/incidents/nc8fykzbyvn8.

4 Likes

Good news @nicolas_sabena, we’ll test and feedback this afternoon.

Will we be given a view on what the issue was, and what will be put in place to stop it reoccurring?

Most of my tenants work, but not my production “demo” tenant specifically. I’m not sure where that is in this mix-up. I’m attempting to build an entirely new tenant for that one for testing purposes, but that’s going to take me some time.

The fix should be in production by now. Are you seeing failures still @creamsteak?

Hi @nicolas_sabena,

Good news. Initial tests are showing that the functionality of the prompt=login is back to normal for us and our workflow is working as before. I’ve just tested the happy path but am going to conduct some more tests tomorrow and will feedback to you.

Many Thanks.

Yes, I’m getting an invalid token back, or at least that’s the error I’m seeing. This is only applying to one of my tenants, my demo tenant. Other tenants work. Problem started at 3PM yesterday, which seems to coincide with this issue. I put in a ticket, but havn’t had a response in two hours. Still getting the same problem right now.

1 Like

If you are getting an invalid token back, it might be a different issue. This problem was present before 3PM yesterday, so it might be unrelated (a configuration issue?). If you filed a support ticket, the support team will pick up from there.

Fixed the issue. It probably fell under this problem, but we had cached an empty token.

1 Like

If you haven’t done so yet, would you mind updating the support ticket to let them know you fixed it? Thanks!

Hi @nicolas_sabena,

I’m happy to say that the fix that has been rolled out has resolved the issue for us. Thanks to all the Auth0 team. :slight_smile: :+1:

2 Likes

Glad to hear that! Let us know if you have any questions in the future!

I’m still getting the issue : here is the log identifier 90020190301153121246989201059008232998097951759114698754

I should mention that my app is not in production yet, so I might not be passing the right parameters to the /authorize endpoint.

EDIT: it looks like the error occurs when I’m providing the “connection” param to the /authorize endpoint. I might investigate in more details later.

1 Like

Also still occurring for us on a production tenant. Relevant log ID:
90020190308093551121702103791907960451639774181081481218

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.