"Password reset" link not appearing in Universal Login form

We use the (new) Universal Login form and the password reset link doesn’t appear in it.
We fail to find out why, and what to do to make it appear.
We tried to check the “Customize Password Reset Page” button but it didn’t do anything.
Is there an option somewhere to enable “password reset” in the new Universal Login form?

Hi @api.video,

Thanks for reaching out.

Does this doc solve your problem?

If that does not address the problem you are running into could you please provide a screen capture of the problem?

Thanks,
Dan

Hi Dan,

I believe the problem is with getting the link to show up on the New Universal Login form, not the Lock-based form.

I’m having the same problem; it’s described in the documentation but I can’t figure out what to do to get the link to show up on the form itself.

  • mike

@hellomike,

Are you using a custom database? This can be the source of the problem if you do not have your custom DB password reset script configured.

Thanks,
Dan

Hi Dan,

I am, through the Wordpress plugin. I don’t see the option to add a password reset script to that database, it only has authenticate and getUser tabs.

It’s worth noting that it’s set to import users into Auth0. I was under the impression that once that happens, the login information is stored on Auth0’s servers and no longer on the custom database.

-m

Hi Dan,

I played around with this some more and it seems like the other tabs on the Custom Database page that let you set things like the password reset script only show up if you turn off the Auth0 User Migration.

Like I said earlier, we’re migrating users into Auth0, so I don’t think that is the problem.

-m

Yeah that doesn’t sound like it should be the problem then. If you select the old universal login does the pw reset link appear?

Hi Dan,

It does show on the old version.

Are there any other settings in the Auth0 admin that pertain to this feature? I can see in the documentation (https://auth0.com/docs/universal-login/new) that it mentions the New Universal Login password reset experience, so it must be in there somewhere.

-m

@hellomike,

Sorry for the delayed response. I have filed a support ticket for this issue. I’ll update here when I learn anything.

Thanks,
Dan

i’m having the same issue - no ‘forgot password’ link on the new universal login page which is turning out to be a major issue:

We had a custom database connected for importing users (over a year ago), and had ‘import to auth0’ turned on (now it’s off - see screenshot below). all new signups are directly into the auth0 hosted database and we are unable to ‘turn off’ the custom database flags:

so what we’ve done is set the database action scripts as follows:

login:

function login (email, password, callback) {
return callback(null, null);
}

get_user:

function getByEmail (email, callback) {
return callback(null, null);
}

all others are set to their default. We also have the following flags:

For anyone in the same position, I’ve now managed to resolve this issue and get the ‘forgot password’ link to show on the new universal login page (even if you previously had an external database connected).

This is how I managed it:

  • go to database action scripts then select ‘Change Password’ and use the following
function changePassword(email, newPassword, callback) {
  return callback(null, null);
}

An update: in order to enable your users to continue to login (if you’ve had a previous external database connection), you MUST leave the Import Users to Auth0 flag turned ON.

Just found out that by turning that off, all users trying to login were presented with a ‘wrong password’ message and were not able to login

This is a known issue and should be fixed as soon as today. I’ll confirm when I hear more.

Thanks for the input and patience everyone.

Warm Regards,
Dan

@oceans @hellomike @api.video

The fix is live. Has the problem been solved for you?

Please let me know.
Thanks,
Dan

Is there any option to open the custom reset password page in new tab or new window of browser. I need to do it. Please reply me ASAP. Thanks…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.