OpenId Connect - Login Error access_denied - unauthorized_client

With my team we are working on a new project that will use an OpenId Connect Integration (ItsMe). At this point I’m struggleling with the configuration of this integration.
And I get this error :
“error”: “access_denied”,
“error_description”: “unauthorized_client”

Clearly the detail of the error didn’t help a lot. I try a few things but still face this error.
Could you help me clarify what I’m missing ?


Hey there @Palyndrome welcome to the community, and sorry for the delayed response!

Were you able to get this resolved?

If you wouldn’t mind providing a bit more detail about the steps you’ve already taken it could be super useful. At which point in the flow are you receiving this error and from where?

Keep us posted!

Hello sorry for the delay of my answers, I was in holiday.

I was not able to solve this issue.
At the moment I’m totally stuck with this.

I tried to change the Application URL, the Grant Type, had a look at the Logs, …
I try to create the User in Auth0, delete it, add roles to it, remove them, same for permissions, …
I implement an application in Angular to try this, the redirect to Auth0 works perfectly fine, I’m also able to be redirect to the OpenId Integration, when the process is finished there, the callback to Auth0 seems to be send the right way and the error happens at that moment.

Hey @Palyndrome sorry for the delayed response here!

Were you able to get this sorted? If not, is there some sort of guide you can refer me to that outlines how you’re attempting to integrate ItsMe with Auth0? I’m unfortunately not familiar with the service :confused: I did find reference to ItsMe in the following integration - Is this the same thing?

Still not sorted sadly :frowning:

It should be the same kind of integration, since Itsme is the product used in Belgium (Netherlands and Luxembourg were just added also) to authentify person with their eId.
You can find their documentation here: itsme®, technical documentation for business
For what I see, the setup on their side seems to work (I’m getting redirect on their platform, I’m able to validate my connection) and it’s when the callback to Auth0 is raised that I have an issue.

Thanks for your help !