OIDC Provider User ID is undefined

I’m trying to setup logins with an OIDC-Conformant Auth0 tenant according to these directions. I can successfully login, but the authenticated User’s normalized user_id doesn’t match the

auth0-oidc|YOUR_AUTH0_CONNECTION_NAME|THE_OIDC_PROVIDER_AUTH0_CONNECTION|THE_OIDC_PROVIDER_USER_ID

convention from the documentation. THE_OIDC_PROVIDER_AUTH0_CONNECTION is set, but THE_OIDC_PROVIDER_USER_ID is undefined. How do I ensure that the UserID from the OIDC Provider Tenant is present in the normalized User ID?

2 Likes

I have the same issue. Strangely the first time I tried the instructions it worked as expected. Repeating them with a different tenant resulted in the behavior you’ve described above. I’ve been unable to narrow it down.

Got a reply from Auth0 Support:

It seems that the auth0-oidc strategy also requires the Legacy User Profile enabled in the tenant to work (which is disabled by default on new tenants). I enabled it for your tenant, so please give it another go and let me know how it goes.

Have confirmed this is something Auth0 Support has to enable and once it was enabled it fixed the issue for me.

They are updating their documentation - https://github.com/auth0/docs/pull/7070/files

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.