Auth0 Home Blog Docs

No Groups information for Enterprise Google connection?

google-apps

#1

We followed the Google Apps guide provided by Auth-0 to set up a connection to our Enterprise Google. My users are able to login using their Google credentials, but when we query for groups, nothing is returned. We have the “Groups” checkbox checked. Not sure why this isn’t working? I see a note saying that extended attributes “requires permission from domain administrator” but there’s no mention on how to provide permissions in the guide? I am a Google Administrator…so not sure what steps I’m missing to get this working.

If this isn’t the right category to ask this, please point me in the right direction. Thank you.


#2

:wave: @hyuan

Can you check if you enabled API access in your Google Apps Admin Console?

If so, when you get the list of Google Apps connections in the dashboard, there’s a link next to the Try button called Setup Instructions. You should should be able to follow the steps to give consent to Auth0 to access the groups and extended profile information (more than just the basic information).

Can you give this a try and let me know how it goes?


#3

I’ve tried twice but got an error each time. I get a Google login prompt, and then request for permissions to access groups. When i grant access, I get an error message saying something went wrong and that there could be a misconfiguration:


#4

This error, if I recall correctly, usually has to do with calling the wrong endpoint or having a bookmarked URL - is it possible to share the URL you have in that window above?


#5

URL below. It’s automatically redirected to it when I click “Allow” on the Google authorize screen. I’ve tried different admin accounts and different browsers with the same results.

URL:
https://zenoss-dev.auth0.com/login/callback?state=o_C4HouEgrBPf3t5-4gFgHT6WNHR36qL&code=4/AADVcijlLbLnpOAGqhKpNKLeeHTjYFcrswYuLuJr0VGcBsIcCxUMq2XEm3ODiwXuWtG2JQmVDMvw-WLovl5xkHM#