Problem statement
After an initial login with Apple ID on mobile, the sign-in process works well. In a second sign-in, Apple uses the native IOS sign-in process, which fails with the error message: “Sign-up not completed”, but without any further specification of the error. Any thoughts on the issue and the resolution?
Cause
The “Sign up not completed” error is usually caused by a configuration mismatch in Apple vs the Auth0 connection.
Solution
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Check if the Client ID and Client Secret saved in the Auth0 connection matches those provided by Apple. We’ve had a couple of users who received this error due to these values being incorrect.
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Check if the Callback URL/domain on the Apple configuration is correct. One potential problem is that you are using a Custom Domain in production, but the regular Auth0 canonical domain during development - so the Apple configuration does not include the Custom Domain.
Also, make sure that the Apple connection is enabled in the Auth0 Application tied to your iOS app. You can do that by going to Auth0 dashboard → Authentication → Social → Apple → Connections tab.