Auth0 Home Blog Docs

Native application

Hi all, following the Documentation of Auth0 native app, I have created a native Applications inside Auth0 platform and downloaded the example files for Ios device from platform. I have also configured domain and client id inside the app and callback url, logout url on application setting, as per guide.

Unfortunately, when I try to login, after the login process, the app shows the login page again and no info is printed on xcode console.

I have checked inside Auth0 Logs and I realized that login is successfully done but the app shows always the login page.

I realized that app doesn’t enter on switch case inside Home View Controller.swift

Does anyone have an idea to how to solve this problem?

Thanks

Hey there Antonio!

Could you share here a bit more info so we can investigate that?

  • What iOS article are you referring to?
  • Can you share the exact piece of code that is not triggered?
  • Also sharing a screenshot of the results in the console will be perfect

Thank you a lot!

Hi Konrad,

I followed this article https://auth0.com/docs/quickstart/native/ios-swift in order to implement login process.

I have added some print in order to debug the code, but it seems that app does not enter on switch statement

In attached screenshot of debug and code of controller with home screen that I see after the logIn process. If you want, I can share the project in pvt.

Thanks in advance

BR

HomeViewController.swift.txt (3.8 KB)

Let me look into that and get back to you soon!