Auth0 Home Blog Docs

Multifactor doesn't work for Database but for Enterprise User

lock
auth0
mfa
auth0-lock

#1

I activated google authentication mfa and it worked as expected for my enterprise users from azure microsoft. When i am logging in with a Database user, however, i get back the silent error of

WE’RE SORRY, SOMETHING WENT WRONG WHEN ATTEMPTING TO LOG IN.

The logs show:

{
“date”: “2018-08-10T13:35:56.421Z”,
“type”: “fcoa”,
“description”: “Multifactor authentication required”,
“connection_id”: “”,
“client_id”: “1Ab02qsUSxuFpnoUteQoKad8nwXYUoBj”,
“client_name”: “fra[…]om”,
“ip”: “2[…]2”,
“user_agent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36”,
“details”: {
“body”: {},
“qs”: {
“client_id”: “1Ab0[…]UoBj”,
“response_type”: “token”,
“redirect_uri”: “http://fr[…].localhost:4200/”,
“state”: “FvP[…]0v-7Q”,
“scope”: “openid profile”,
“realm”: “dev[…]aff”,
“login_ticket”: “-TBEy[…]p73v”,
“response_mode”: “web_message”,
“prompt”: “none”,
“auth0Client”: “ey[…]uMyJ9fQ==”
},
“connection”: “de[…]aff”,
“error”: {
“message”: “Multifactor authentication required”,
“oauthError”: “login_required”,
“type”: “oauth-authorization”
},
“session_connection”: “de[…]ff”
},
“hostname”: “a[…]com”,
“user_id”: “au[…]2fe”,
“user_name”: “rob[…]om”,
“audience”: “https://a[…]m/userinfo”,
“scope”: [
“openid”,
“profile”
],
“log_id”: “9002[…]6907234”
}

I found a similar issue here, but I redirect true did not work out. Same for the SSO = true parameter other topics requested.

Package Dependency: “auth0-lock”: “11.5.2”,

options = {
allowSignUp: false,
allowAutocomplete: false,
autoclose: true,
rememberLastLogin: false,
auth: {
redirect: true,
sso: true,
params: {
scope: this.bootstrap.auth0Scope,
}
}

Thanks!